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What is Math?

Math is OpenOffice.org (O0O0)’s component for writing mathematical
equations. It is most commonly used as an equation editor for text
documents, but it can also be used with other types of documents or
stand-alone. When used inside Writer, the equation is treated as an
object inside the text document.

The equation editor is for writing equations in symbolic form (as
Note in equation 1). If you want to evaluate a numeric value, see the
Calc Guide.

(1)

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating
Selection window appears. You will also see a small box (with a gray
border) in your document, where the formula will be displayed, as
shown in Figure 1.
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Figure 1. Equation Editor, Selection window, and
location of resulting equation.
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The equation editor uses a markup language to represent formulas. For
example, %beta creates the Greek character beta (). This markup is
designed to read similar to English whenever possible. For example, a

. a
over b produces a fraction: 3

Entering a formula

There are three ways to enter a formula:
« Select a symbol from the Selection window.

« Right-click on the equation editor and select the symbol from the
context menu.

« Type markup in the equation editor.

The context menu and the Selection window insert the markup
corresponding to a symbol. Incidentally, this provides a convenient way
to learn the OOoMath markup.

Click on the document body to exit the formula editor.

Note Double-click on a formula to enter the formula editor again.

The Selection window

The simplest method for entering a formula is the Selection window,
shown in Figure 1.

- Categories
a (2) %
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ﬂ

a-b £ as=b a/b avb

Figure 2. Symbols are divided into categories

The Selection window is divided into two main portions.

« The top shows the symbol categories. Click on these to change
the list of symbols.

« The bottom shows the symbols available in the current category.
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You can hide (or unhide) the Selection window with View >

Tip Selection.

Example 1: 5x4
For this example we will enter a simple formula: 5x4 On the Selection
window:

1) Select the top-left button of the categories (top) section
(Figure 3).

2) Click on the multiplication symbol (shown in Figure 3).

Unary/binary operators

/
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Figure 3. Unary/binary operators

When you select the multiplication symbol on the Selection window,
two things happen:

« The equation editor shows the markup: <?> times <?>

« The body of the document shows a gray box with the figure:
X

A D A

4 3

—— | .

-

4 3

Figure 4. The multiplication symbol

The “ <?> ” symbols (Figure 4) are placeholders that you can replace
by other text. The equation will update automatically, and the result
should resemble Figure 5.
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“5x4e
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Figure 5. Result of entering "5" and "4" next to
the "times" operator

To keep the equation from updating automatically, select View
>AutoUpdate display.

To update a formula manually, press F9 or select View >
Update.

Tip

Right-click menu

Another way to access mathematical symbols is to right-click on the
equation editor. This produces a menu as shown in Figure 6.

5 times 4] -
Unary/Binary Operators b +a
Relations 3 -a
> Set Operations 3 +-a
Functions 3 -+a
Operators AR
Attributes » a-b
Brackets 3 a cdot b
Formats » T atimes b
Others 3 a*b
a over b
adivb
alb
acirc b

a wideslash b
a widebslash b

Figure 6. Right-click menu

The entries in this menu correspond exactly to those in the

Note Selection window.
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Markup

You can type the markup directly on the equation editor. For example,
you can type “5 times 4” to obtain 5x4. If you know the markup, this
can be the fastest way to enter a formula.

As a mnemonic, the formula markup resembles the way the

Tip formula reads in English.

Below is a short list of common equations and their corresponding
markup.

Display Command Display Command
a=b a=b Ja sqrt {a}
a’ a~2 a, an
f £(x)dx int f(x) dx D a, sum a n
a<b a<=b 00 infinity
aXb a times b Xy x cdot y

Greek characters

Greek characters («, B,y, 0, etc) are common in mathematical
formulas. These characters are not available in the selection box or the
right-click menu. Fortunately, the markup for Greek characters is
simple: Type a % sign followed the name of the character, in English.

« To type a lowercase character, write the name of the character in
lowercase.

« To type an uppercase character, write the name of the character
in uppercase.

See the table below for some examples.

Lowercase Uppercase

%salpha —» « SALPHA — 4
sbeta — B %SBETA — B
%gamma — vy %GAMMA — I
%psi - Y %PS1I i 4
Ssphi — ¢ SPHI —> &
%theta —» 0 STHETA — @
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A complete table of Greek characters is included in Chapter 16

Note (Math Objects) in the Writer Guide.

Another way to enter Greek characters is by using the catalog window.
Go to Tools > Catalog. The catalog window is shown in Figure 7.
Under “Symbol Set” select “Greek” and double-click on a Greek letter
from the list.

Shasn ks

Symbol set Insert
Greek =

Close
A B X A EHT I K A ™
MNOQO®ITY pXT Edit...
&Y E ).’ﬁ X & € n
¥y Lok A opow oo ¢
Wop o 8 v £ @ W™ p
A

alpha

Figure 7. Catalog - used for entering Greek characters

Example 2: © =~ 3.14159

For this example we will suppose that:

« We want to enter the above formula (the value of pi rounded to 5
decimal places).

« We know the name of the Greek character (“pi”).
« But we do not know the markup associated with the =~ symbol.

Step 1: Type “%” followed by the text “pi”. This displays the Greek
character .

Step 2: Open the Selection window (View > Selection).

Step 3: The = symbol is a relation, so we click on the relations button

asb_ If you hover the mouse over this button you see the tooltip
“Relations” (Figure 8).
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2 A
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Figure 8. Tooltip indicates
the "Relations" button.

Step 4: Delete the <?> text and add “3.14159” at the end of the
equation. Hence we end up with the markup “ %pi simeq 3.14159 ”.
The result is shown in Figure 9.

s m=314150 -

MDA

4 4

i simeq 3.14159] -

4 .4

Figure 9. Final result

Customizations

Formula editor as a floating window

As seen in Figure 2, the formula editor can cover a large part of the
Writer window. To turn the formula editor into a floating window, do
this:
1) Hover the mouse over the editor frame, as shown in Figure 10.
2) Hold down the Control key and double-click.
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F-=m "2

E:= mc™2
4

Figure 10. Hold down the Control key and
double-click on the border of the math editor
to turn it into a floating window.

Figure 11 shows the result. You can make the floating window back
into an embedded frame, using the same steps. Hold down the Control
key and double-click the window frame.

Cejgrigriziglels

-

4 k

Figure 11. Equation editor as a floating window

How can | make a formula bigger?

This is one of the most common questions people ask about OOoMath.
The answer is simple, but not intuitive:

1) Start the formula editor and go to Format > Font size.
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Figure 12. Changing the font size for a formula

2) Select a larger font size under “Base Size” (top-most entry), as
shown in Figure 12.

FOTASTEES:

Base size hept - oK
Relative sizes cancel

Lz 100% -

Indexes 60% = Default

Eunctions 100% -

Operators 100% -

Limits 60% =

Figure 13. Edit "Base size" (top) to
make a formula bigger.

The result of this change is illustrated in Figure 13.

Before: =3 1459

After: =23 14159

Figure 14. Result of changing
the base font size.
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Formula layout

The most difficult part of using OOoMath comes when writing
complicated equations. This section provides some advice about
writing complex formulas.

Brackets are your friends

OOoMath knows nothing about order of operation. You must use
brackets to state the order of operations explicitly. Consider the
following example:

Markup Result

2 over x + 1 2+1

X

2 over {x + 1}

x+1

Equations over more than one line

Suppose you want to type an equation covering more than one line. For

x=3

example: = _ 1

Your first reaction would be to simply press the Enter key. However, if

you press the Enter key, though the markup goes to a new line, the
resulting equation does not. You must type the newline command
explicitly. This is illustrated in the table below.

Markup Result

X =3 x=3y=1
y =1

X = 3 newline x=3
y=1 y=1

Getting Started with Math
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Common problem areas

How do | add limits to my sum/integral?

The “sum” and “int” commands can (optionally) take in the parameters
“from” and “to”. These are used for lower and upper limits
respectively. These parameters can be used singly or together. Limits
for integrals are usually treated as subscripts and superscripts.

Markup Result

sum from k = 1 to n a kK L
Zak
k=1

int from 0 to x f(t) dt
or
int 0°x f(t) dt

int from Re f

f(¢)dt or f:f(t)dt

;. o%k

f

2}1

D =

sum to infinity 2°{-n}

Not For more details on integrals and sums, see Chapter 16 (Math
ote Objects) in the Writer Guide.

Brackets with matrices look ugly!

For background, we start with an overview of the matrix command:

matrix { a # b # c # d } a b
c d

Rows are separated by two #’s and entries within each row are

Note separated by one #.

The first problem people have with matrices is that brackets do not
“scale” with the matrix:
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Result

( matrix { a# b ##t c#d } ) (ab)

OOoMath provides “scalable” brackets. That is, the brackets grow in
size to match the size of their contents. Use the commands /left( and
right) to make scalable brackets.

left( matrix { a # b # c # d } right)

Tip Use left[ and right] to obtain square brackets.

How do | make a derivative?

Making derivatives essentially comes down to one trick: Tell OOo it’s a
fraction.

In other words, you have to use the “over” command. Combine this
with either the letter “d” (for a total derivative) or the “partial”
command (for a partial derivative) to achieve the effect of a derivative.

Markup Result

{df} over {dx} af
dx

{partial f} over {partial y} af
Oy

{partial~2 f} over {partial t"2} >f
or’

Notice that we had to use squiggly brackets to make the

Note derivative.

Numbering equations

Equation numbering is one of OOoMath’s best hidden features. The
steps are simple, but obscure:

1) Start a new line.
2) Type “fn” and then press F3.

The “fn” is replaced by a numbered formula:
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E=mc’ (2)

Now you can double-click on the formula to edit it. For example, here
is the Riemann Zeta function:

()= L )

n=1 N

You can reference an equation (“as shown in Equation (2)”) with these
steps:

1) Insert > Cross-reference..

2) Click on the References tab (Figure 14).

3) Under Type, select Text.

4) Under Selection, pick the equation number.

5) Under Format, choose Reference.

6) Click Insert.
Done! If you later add more equations to the paper before the

referenced equation, all the equations will automatically renumber and
the cross-references will update.

Fields e

Document |Cross-references | Functions | DocInformation | Variables | Database

Tvpe Selection
Set Reference i
Insert Reference (z
Headings (3

Mumbered Paragraphs
Texk

Figure

Bookmarks

Insert reference to

Page

Chapter

Reference
above/Below

As Page Stvle
Categary and Mumber
Caption Text
rumbering

[ Insert ][ Close ][ Help ]

Figure 15. Inserting a cross-reference to an equation number

Tip To insert the equation number without parenthesis around it,
choose Numbering instead of Reference under Format.
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